Install HandBrake CLI v0.9.9 on CentOS 6.4

This is a quick guide to help you get HandBrakeCLI installed on CentOS 6.x. This was specifically tested with HandBrake v0.9.9 and CentOS v6.4, but it should also work for the future versions as long as nothing major changes.

First, make sure you have the prerequisites installed:

yum groupinstall 'Development Tools' 
yum groupinstall 'Development Libraries' # Ignore for CentOS 6.5
yum install fribidi-devel gtk+ yasm webkitgtk-devel gstreamer-devel gstreamer-plugins-base-devel bzip2-devel
yum install libgudev1-devel libnotify-devel libass-devel libsamplerate-devel libogg-devel libtheora-devel libvorbis-devel


Checkout the latest version from SVN Download the latest version from their website, build it without GTK support:

cd /usr/local/src/
wget -O HandBrake-0.9.9.tar.bz2 http://handbrake.fr/rotation.php?file=HandBrake-0.9.9.tar.bz2
tar -jxvf HandBrake-0.9.9.tar.bz2
cd HandBrake-0.9.9
./configure --launch --disable-gtk
cp build/HandBrakeCLI /usr/local/bin/

The –launch argument will start HandBrake’s gmake script that will download the other libraries it needs, compile them, and then statically link them to the HandBrakeCLI executable it builds. This can take a little while, depending on your available resources, and it requires an internet connection. If you get build errors complaining about missing *.h files, make sure you have the lib*-devel installed for that missing header.

Note: The trunk will likely be updated soon-ish, so if you’re looking for 0.9.9 specifically you can get the source from SourceForge.

Edit: Looks like they removed public access to SVN.

4 Comments


  1. Thanks for the nice write-up. I also needed to do the following on a fresh installation of CentOS 6.5 (installed initially as “desktop”).

    – Added the EPEL repository
    – Added bzip2-devel-1.0.5-7.el6_0.x86_64

    With that, it built. Oddly, it seems that with 6.5 there is no longer a separate “Development Libraries” group. It still built fine without it.

    John


  2. I believe you’re right. I don’t see Development Libraries in the list anymore. I’ll add a note to the bash lines above.


  3. i have done everything…
    last question now how to access this ??
    do i need to open this in web-browser by typing my server ip??

    please help me i am new in this.

    thank you

Leave a Reply

Your email address will not be published. Required fields are marked *